Video capture USB stick
video - usb adaptor - gardenature
Ezcap 1168 - gardenature
video usb grabber-gardenature.co.uk
Video capture USB stick
video - usb adaptor - gardenature
Ezcap 1168 - gardenature
video usb grabber-gardenature.co.uk

USB 2.0 Video Capture for Windows & Mac 

A quick and easy way of connecting your gardenature camera to your Laptop, PC or Mac to capture High-quality video and audio files. Compatible with Windows OS and Mac OS X. 

Package includes a USB capture stick and easy to use CD video-editing software which enables you to watch live, take photos and record movies. A step by step guide Video Studio movie wizard makes the functionality simple to follow, you can also upload and share finished projects on-line.

This product requires a CD drive, a spare USB 2.0 port and an internet connection for installation. 

Ezcap 1168 Features: 

  • Professional and easy to use video editing software
  • Plug & Play
  • Capture Video & Audio though USB 2.0 interface
  • Supports Brightness, Contrast, Hue, and Saturation control
  • Captures audio without the need for a sound card
  • Support For All Formats: record in DVD+/-R/RW, DVD+/-VR, and DVD-Video

 

Ezcap 1168 Specifications:

  • Supports NTSC, PAL Video format 
  • Video input: One RCA composite, One S-Video
  • Audio input : Stereo audio (RCA)
  • Dimension :  (L)78 x (W)30 x (H)20mm
  • High quality video resolution: PAL: 720 x 576 @ 25fps

 

Package Contents: 

  • USB Video Grabber with Audio
  • Quick Installation Guide
  • Software CD. Includes drivers, Video Editing/Converting software, and Manual for Windows and Mac

 

System Requirements: 

For Windows OS:

  • P4 1.7GHz CPU or above
  • 512MB RAM or above  
  • VGA card with 32MB memory 
  • One available USB 2.0 port 
  • CD Drive
  • Internet Connection (for installation)  
  • Microsoft windows XP/Vista/7/8/10
  • 32bit / 64bit


For Mac OS X: 

  • 1.5Ghz Intel Core Solo or above
  • 1GB 667MHz DDR2 SDRAM or more
  • One available USB 2.0 port
  • CD DVD Rom Drive
  • Internet Connection (for installation)   
  • Mac OS X 10.5.6 or later